PDF Manage not working due to Azure Changes

Major incident PDF Manager Amesto Online Services
55 minutes

Updates

Resolved

An update was applied to solve the problem.

March 16, 2020 · 11:51 CEST
Investigating

Azure updates seems to affect PDF Manager UI

March 16, 2020 · 10:59 CEST