PDF manager has slow performance.

Minor incident PDF Manager Amesto Online Services
2 days, 23 hours, 42 minutes

Updates

Resolved

We have optimized our servers, at it has improved the performance for PDF manager.

AmestoApps team support@amestoapps.com

March 15, 2020 · 16:38 CEST
Investigating

Some users experience slow performance, we will investigate.

Amesto apps team.

March 12, 2020 · 17:00 CEST