PDF Manager

Minor incident PDF Manager Amesto Online Services
4 hours, 13 minutes

Updates

Resolved

The PDF manager issue is now solved. You might have to flush in SuperOffice or clear browser cache. Amesto Apps team

March 4, 2020 · 14:09 CEST
Issue

Hi We are experiencing some issues with our PDF manager, it should be fixed within some hours. Kind regards Amesto apps team.

March 4, 2020 · 09:59 CEST