NO Bank ID isn't working

Major incident Amesto Online Services Online Signature
2022-06-20 21:06 CEST · 2 hours, 7 minutes, 59 seconds

Updates

Resolved

All sign methods are working again.

Amesto Apps.

June 20, 2022 · 23:14 CEST
Investigating

Only Ink sign will work as a sign method, else you will get a blank page when sending.

Amesto Apps.

June 20, 2022 · 21:27 CEST
Investigating

It will not work if you use NO Bank id as sign method, you get a blank page when sending. We and Signicat.com are working on it.

Amesto Apps.

June 20, 2022 · 21:14 CEST

← Back