PDF Conversion server Down

Major incident Amesto Online Services Online Signature PDF Manager PDF Conversion server
2022-06-03 08:58 CEST · 22 minutes, 6 seconds

Updates

Resolved

-RESOLVED-

The PDF Conversion server is online again. You may use PDF Manager and Online Signature again. Sorry for the inconvenience.

AmestoApps Team.

June 3, 2022 · 09:20 CEST
Investigating

Our PDF Conversion server is down, this affects PDF Manager and Online Signature, we are working on it.

AmestoApps Team.

June 3, 2022 · 09:00 CEST

← Back