Certificate Error

Major incident Amesto Online Services Online Signature Online Dashboard Online Dashboard - Tunnel Server
2022-05-02 11:39 CEST · 3 hours, 1 minute, 3 seconds

Updates

Resolved

Online Signature is up and running.

Sorry for the inconvenience AmestoApps Team

May 2, 2022 · 14:40 CEST
Issue

There are some certificate issues that will cause Online Signature to fail. We are working on it.

AmestoApps team

May 2, 2022 · 11:45 CEST

← Back