Authentication issues

Major incident Amesto Online Services Online Signature
2021-11-26 09:47 CEST · 1 hour, 49 minutes, 15 seconds

Updates

Resolved

The issue at Signicat.com is solved.

Amesto Apps

November 26, 2021 · 11:36 CEST
Investigating

Signicat.com is having issues with Authentication, Online Signature might fail when Sigee signs a document. For further developments: https://status.signicat.com/

Amesto Apps.

November 26, 2021 · 09:50 CEST

← Back