Certificate error

Major incident Amesto Online Services EDS Online Online Signature PDF Manager
2021-05-28 08:59 CEST · 33 minutes, 25 seconds

Updates

Resolved

All systems are updated and ready to use. Sorry for the Inconvenience

Amesto Apps Team

May 28, 2021 · 09:32 CEST
Issue

Our certificate is not updated and is causing apps to fail, we are working on it.

Amesto Apps team

May 28, 2021 · 09:02 CEST

← Back