Unstable service

Minor incident Amesto Online Services Online Signature
2021-01-21 11:23 CEST · 13 minutes, 12 seconds

Updates

Resolved

The issue with Signicat signature services is now resolved.

Amesto Apps team

January 21, 2021 · 11:36 CEST
Issue

Signicat.com reports that signature services may be unstable for the moment. As a result of this generating signature may fail occasionally or frequently.

Amesto Apps Team

January 21, 2021 · 11:24 CEST

← Back