Update software

Minor incident Amesto Online Services Online Signature
2020-08-31 12:30 CEST · 2 days, 25 minutes, 59 seconds

Updates

Resolved

The Online Signature is again working as it should

September 2, 2020 · 12:55 CEST
Issue

We need to update the Online signature Software., will be down for 5-10 min.

Amesto Apps team

August 31, 2020 · 12:22 CEST

← Back