Merge with PDF manager is down

Minor incident Beezy365Apps Online Services PDF Manager PDF Conversion server
2024-12-05 04:26 -11 · 3 weeks, 9 hours, 44 minutes

Updates

Update

We are now working on a bug fix, until we are ready, please use this workaround.
Click on the “Open in separate window” lower right hand side, in the new window, you can use the merge function and more.

Please let us know, if you need help.
support@beezy365apps.com

Beezy365apps team

December 7, 2024 · 05:24 -11
Investigating

It’s not possible to use merge function in PDF Manager Online
we are investigating the issue.

Beezy365apps Team

December 5, 2024 · 04:26 -11

← Back