EDS Online is down

Major incident Beezy365Apps Online Services EDS Online
2023-11-20 20:55 -11 · 7 hours, 27 minutes

Updates

Resolved

EDS Online is up and running.

sorry for the inconvenience.

Amesto Apps Team.

November 21, 2023 · 04:22 -11
Update

We have ended our investigation and are now fixing the problem at hand, and expect to release new software later today.
Thank you for your understanding.
If you have any questions, please contact us at support@amestoapps.com

Amesto Apps Team

November 21, 2023 · 01:08 -11
Investigating

EDS Online is down, we are working on it.

Amesto Apps Team

November 20, 2023 · 20:55 -11

← Back