Can't open the PDF manager tab

Minor incident PDF Manager Amesto Online Services
13 hours, 7 minutes

Updates

Resolved

New software is deployed.

Amesto Apps Team

May 11, 2020 · 20:36 CEST
Issue

Some users experience a login screen flashes when trying to use PDF manager with SuperOffice Online, we are investigating. This only applies to SuperOffice Online Users.

AmestoApps Team

May 11, 2020 · 07:36 CEST