Unstable Online signature

Major incident Online Signature Amesto Online Services
2 hours, 38 minutes

Updates

Resolved

We have released new software, and issues should be solved. please feel free to report any issues to support@amestoapps.com We apologize for any inconvenience caused.

AmestoApps Team

May 4, 2020 · 17:46 CEST
Issue

Unstable Online signature, we are working on it.

Amesto Apps.

May 4, 2020 · 15:12 CEST