Unable to convert Visio files

Minor incident Beezy365Apps Online Services PDF Manager
2023-01-12 04:43 -11 · 1 week, 20 hours, 48 minutes

Updates

Resolved

It is now possible to convert Visio files.
Sorry for the inconvenience.

AmestoApps Team.

January 20, 2023 · 01:32 -11
Investigating

PDF Manager is unable to convert Visio files, we are working on it.

AmestoApps team

January 12, 2023 · 04:46 -11

← Back