PDF manager hangs with spinner

Major incident PDF Manager Amesto Online Services
3 hours, 9 minutes

Updates

Resolved

New software has been released for the improvement of hanging spinner.

Amesto Apps Team

March 31, 2020 · 16:16 CEST
Issue

PDF manager can stall with a spinner on the screen, we will investigate and have it fixed asap. estimated time 1-2 hours.

Amesto Apps Team

March 31, 2020 · 13:13 CEST